CADLUS PCB , Viewer バージョンアップ情報

CADLUS Viewer Ver6.0.7695 リリース
CADLUS Viewer Ver6.0.7522 リリース
CADLUS Viewer Ver6.0.7513 リリース
CADLUS PCB Ver6.0.7387 リリースノート

【全体】

  • 物理層番号の表記を”Px”を”Lx”に変更しました。
  • 論理層名称の部品面をA面に、半田面をB面に変更しました。
  • 登録部品の“確認フラグ”に確認3を追加しました。

【入力】

  • 部品参照名付加で数値部の指定桁数を4桁までを5桁までにしました。
  • 参照名付加に参照名の数値部の増分を指定できる様にしました。
  • XYと円周繰り返コピーで配置部品の参照名の数値部の増分を指定できる様にしました。
  • 結線入力の「線幅・ビア設定」に線幅表示順の”線幅”順か”Dコード”順かの設定を追加しました。
  • [面取」に打ち抜きの無い輪郭線データも対象にしました。

【ネット入力】

  • [チェック]に[未配置部品表示]ボタンを追加しました。
  • 他社ネット”STELLER CAD”フォーマットを追加しました。

【その他】

  • スタックテーブルの設定時に、THとNTHの設定チェックを穴径とランド径で行う様にしました。
  • マウント出力の“フリーフォーマット”でデフォルトのファイル拡張子を設定できる様にしました。
  • CADLUSの部品配置チェック用の3D表示を追加し、環境設定に3D表示をVRMLを利用するかのチェックを追加しました。(Viewer共通)
  • 基板補助機能に「基板データ照合」で、同じ基板名でも照合できる様にしました。
  • バッチDRC(1層、2層、特殊)でエラーがあった場合、エラー個数をクリックするとエラーリストを表示し、
    その表示された座標値をクリックするとその箇所が自動スクロール表示する様にしました。
  • 自動ベタ発生の角パッド(パッド/ランド)の抜き方で、四隅を円弧の形状に統一しました。
  • 基板ユーティリティの基板レポートの部品表の最後に合計個数表示を追加し、
    部品表入力の[レポート]ボタンを同じ帳票の為に削除しました。
  • 基板ユーティリティのデータ変換の”結線 線幅“変更で、変更先を丸のDコードを全て表示していましたが、
    結線線幅のみの表示にしました。
  • 部品ユーティリティの”確認”に確認3を追加しました。
  • 連続印刷のHPGL出力で複数図面出力時はファイル指定ではなくフォルダ指定に変更しました。
    その時キャンセルした場合、”処理が終了しました”というメッセージは表示しない様にしました。
  • 連続印刷に”基板領域は全データ対象”のチェックボックスを追加しました。

【制限事項】

  • マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
    DXF出力中に”動作を停止しました。”とエラー表示されます。
CADLUS Viewer Ver6.0.6387 リリースノート
  • 部品配置チェック用の3D表示を追加し、「設定」-「表示設定」に3D表示をVRMLを利用するかのチェックを追加し、
    オフにしますとVRMLの表示ソフトをインストールなしでも、部品配置チェック用の3D表示が行えます。
  • 「基板データ照合」を追加いたしました。開いている基板と過去の基板の変更箇所が分かります。
    また、ガーバーファイルの読み込み照合もできる様にしました。
  • 図形属性表示にてB面配置の部品の配置角度にカッコ内にB面側からの配置角度も表示する様にしました。
CADLUS Viewer Ver6.0.6721 リリース
CADLUS PCB Ver6.0.7122 リリースノート

【入力】

  • 辺移動に指定移動(結線辺移動のような移動)を追加し、グリッドに乗る様にしました。主に輪郭線の修正で使用します。
  • ”シルク生成”にて作成したシルク文字とその配置部品を“回転”した場合、一部の配置部品が回転しない不具合を修正しました。
  • 「漢字入力」で裏配置部品も自動で作成される様にしましたので、“表裏切り替”で裏配置も表配置もできる様になりました。
  • 部品生成時に配置基準点(0,0)に対する確認メッセージは表示しないようにしました。

【ネット入力】

  • ネット編集において削除データがエラーチェックされる不具合を修正しました。
  • ネットのキー入力で、数字繰り上げ時にR01の繰り上げがR2ではなくR02になるよう変更しました。
  • ネット入のバンクファイル入力時、端子番号の重複エラーの表記に誤り修正しました。

【その他】

  • 自動ベタ発生の角パッド(パッド/ランド)の抜き方で、四隅を円弧の形状に統一しました。
  • 自動ベタ発生で、ベタが発生しない場合はエラーメッセージを表示する様「にしました。
  • 物理層設定画面の表示枠を物理層20まで、物理層数に合わせて表示するよう変更しました。
  • 自動ベタ発生で処理中に[実行]ボタンは押せないようにしました。

【制限事項】

  • マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
    DXF 出力中に”動作を停止しました。”とエラー表示されます。
CADLUS Viewer Ver6.0.7122 リリース
CADLUS Viewer Ver6.0.7088 リリース
CADLUS PCB Ver6.0.6823 リリースノート

【全 体】

  • メニュー名"領域点移動"を"外形サイズ変更"に変更しました。

【入力・編集】

  • 寸法線入力に“累進寸法”を追加しました。
  • 「漢字入力」にローマ字数字の“ⅠⅡⅢⅣⅤⅥⅦ Ⅷ ⅨⅩ”を追加しました。
    バージョンアップ後の最初の起動時"バージョンアップを確認しました。
    PARTフォルダの標準部品ライブラリの置き換えを行いますか?"というメッセージで「はい」をクリックして下さい。
  • 直線入力に”終点ラバー表示”の設定ボタンを追加し、入力途中で終点位置が分かる様にしました。

【ネット入出力】

  • ガーバー出力時、大きな抜き円データで塗りつぶし線が外側に僅か出る不具合を修正しました。
  • ガーバー出力時、R付きパターンで線幅が途中で変わりテーパーが有る場合、最後の線分が出力されない場合がある不具合を修正しました。
  • マウント出力で基板の右下原点から座標出力出来る様にしました。
  • NC出力時のパラメータが保存されない不具合を修正しました。

【バッチDRC処理】

  • ”1層“のチェックボタン”輪郭”にチェックを入れると、自分自身の輪郭データが重なった場合はエラーにする様にしました。
    ガーバー出力で、自分自身の輪郭データが重なった箇所は抜きになってしまいます。
  • ”特殊“に”パッドオンビアの検出“を追加しました。
  • ”特殊“の鋭角チェックで本来エラーにならない箇所でエラーになる不具合を修正しました。
  • ”特殊“に”パタン・パッド間鋭角チェックにパタン間チェック”を追加しました。
  • “特殊”に"部品ランドとCOCのギャップチェック"を追加しました。
  • “特殊“に“部品ランドとビアのギャップチェック"を追加しました。

【その他】

  • 部品ユーティリティの” 部品図印刷”で表示層がオンでも穴しか印刷されない不具合を修正しました。
  • 連続印刷で“ランドサプレス”をオンにするするとデータもサプレスされてしまう不具合を修正しました。
  • 部品表入力のCADLUS側の部品名と部品表側の部品名の、部品対応ファイルは基板単位では無く、システム単位で保存する様に変更しました。
    [パラ書き込み]と全設定をクリアーにする[初期化]ボタンを追加しました。
  • 領域DRCの処理スピードをアップしました。

【制限事項】

  • マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
    各操作中に”動作を停止しました。”とエラー表示されます。
CADLUS Viewer Ver6.0.6887 リリース
CADLUS Viewer Ver6.0.6823 リリース
CADLUS Viewer Ver6.0.6752 リリース
CADLUS Viewer Ver6.0.6743 リリース
CADLUS Viewer Ver6.0.6674 リリース
CADLUS PCB Ver6.0.6339 リリースノート

【全 体】

  • 登録部品の部品種別に下記の8個を追加しました。固定で、名前の変更などは出来ません。
    SON SOT LGA DFN CLCC LPCC SOP-H QFP-H

【入力・編集】

  • 径寸法線入力で対象データが直線の場合、45度の線でなくてもエラーとせずに表示する様に修正しました。
    カット寸法ではなく、辺の長さに変更しました。

【ネット入出力】

  • CADLUSサーキットから出力されるネットファイルは、アシストツールの[ネット入力]でも、[ネット情報入力]の[ネット入出力]-[ネット入力]でも読み込める様に修正しました。
    (従来は[ネット情報入力]の[ネット入出力]-[他基板ネット入力]のみ読み込めました)
  • ”KiCad2”フォーマットのネット入力を追加しました。
  • “CR5000”フォーマットで1データが複数レコードの場合エラーとなる不具合を修正しました。
  • アシストツールの[ネット入力]で信号名が50文字を越えた場合、信号名変更リストを表示する様にしました。
  • 各信号名にテストパッド用のネットを追加する機能を追加しました。

【その他】

  • 穴図出力の“DXF出力”で出力したDXFファイルを、一部のDXFファイル読み込みソフトで、帳票の枠線と文字位置が
    ずれる場合がある為、文字の出力を変更し、極力ずれない様に修正しました。
  • 部品生成でパターンにテーパーが付いている場合、そのテーパーが2重に作成される場合がある不具合を修正しました。
  • アシストツールの面付でのVカット生成時に基板サイズの小数点以下が、微小な値があると最後のVカット線が出力されない不具合を修正しました。
  • 基板チェック設定に”自動バックアップ中は基板チェックをしない”を追加しました。

【制限事項】

  • マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
    各操作中に”動作を停止しました。”とエラー表示されます。
CADLUS Viewer Ver6.0.6339 リリースノート
  • 半田面視表示で同電位表示すると、部品面視表示と異なる不具合を修正しました。

【制限事項】

  • マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
    各操作中に”動作を停止しました。”とエラー表示されます。
CADLUS PCB Ver6.0.6247 リリースノート

【全 体】

  • データ表示画面の右側の論理層表示をレイヤーリストとして表示も出来る様にしました。
    使用層のみ表示され、穴表示のオンーオフも便利になります。
    メニュー「表示」-「表示バー」-「レイヤーリスト」
  • 登録部品の部品種別に下記の5個を追加しました。固定で、名前の変更などは出来ません。
    SON SOT LGA DFN CLCC LPCC

【入力・編集】

  • 径寸法線入力で対象データが直線の場合、45度の直線でなくてもエラーとせずに表示する様に修正しました。
    カット寸法ではなく、辺の長さに変更しました。
  • 線幅無しの輪郭データが作成される場合のある不具合を修正しました。
  • 直径がゼロの円・輪郭円データが作成される場合のある不具合を修正しました。
  • 不正な円弧データが作成される場合のある不具合を修正しました。

【ネット入出力】

  • CADLUSサーキットから出力されるネットファイルは、アシストツールの[ネット入力]でも、[ネット情報入力]の
    [ネット入出力]-[ネット入力]でも読み込める様に修正しました。
    (従来は[ネット情報入力]の[ネット入出力]-[他基板ネット入力]のみ読み込めました)
  • CR5000フォーマットの入力で、1データが複数レコードの場合エラーとなる不具合を修正しました。
  • アシストツールの[ネット入力]で信号名が50文字を越えた場合、信号名変更リストを表示する様にしました。

【その他】

  • 穴図出力の“DXF出力”で出力したDXFファイルを、一部のDXFファイル読み込みソフトで、帳票の枠線と文字位置が
    ずれる場合がある為、文字の出力を変更し、極力ずれない様に修正しました。

【制限事項】

  •  マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
    各操作中に”動作を停止しました。”とエラー表示されます。
CADLUS Viewer Ver6.0.6247 リリースノート

【全 体】

    • データ表示画面の右側の論理層表示をレイヤーリストとして表示も出来る様にしました。
      使用層のみ表示され、穴表示のオンーオフも便利になります。
      メニュー「表示」-「表示バー」-「レイヤーリスト」
    • アシストツールに実装用部品表出力の機能を追加しました。

【入力・編集】

    • 径寸法線入力で対象データが直線の場合、45度の直線でなくてもエラーとせずに表示する様に修正しました。

【ネット入出力】

    • CADLUSサーキットから出力されるネットファイルは、アシストツールの[ネット入力]でも、[ネット情報入力]の
      [ネット入出力]-[ネット入力]でも読み込める様に修正しました。
      (従来は[ネット情報入力]の[ネット入出力]-[他基板ネット入力]のみ読み込めました)
    • [ネット入力]でCADLUSのサーキットやCADLUS Oneなどの他基板のネットファイルを指定した場合でも、
      確認メッセージ後に読み込める様にしました。
      [ネット入力(マニュアル)]では読めません。
      “アシストツール”の[ネット入力]でも読み込めます。

【その他】

    • 穴図出力の“DXF出力”で出力したDXFファイルを、一部のDXFファイル読み込みソフトで、帳票の枠線と文字位置が
      ずれる場合がある為、文字の出力を変更し、極力ずれない様に修正しました。

【制限事項】

  • マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
    各操作中に”動作を停止しました。”とエラー表示されます。
CADLUS PCB Ver6.0.6198 リリースノート
  • 一部のガーバーデータで、複数ファイルの読み込みが出来ない不具合を修正しました
    その為、”自動層割当”は行われなくなりました。

【制限事項】

  • マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
    各操作中に”動作を停止しました。”とエラー表示されます。
CADLUS Viewer Ver6.0.6198 リリースノート

【ガーバーイン】

  • 一部のガーバーデータで、複数ファイルの読み込みが出来ない不具合を修正しました。
CADLUS PCB Ver6.0.6136 リリースノート

【入力・編集】

    • 1端子部品の結線追従部品移動で結線全体が動いてしまうことがある不具合を修正しました。
    • 寸法線入力の“内側寸法”、“外側寸法”で始点の引き出し線の線幅の半分の補正がされていない不具合を修正しました。

【ネット入出力】

    • アルゴレックスフォーマットのネットデータで、先頭データのカッコ内の部品名にハイフンがあっても
      自動認識される様に修正しました。
    • [ネット入力]でCADLUSのサーキットやCADLUS Oneなどの他基板のネットファイルを指定した場合でも、
      確認メッセージ後に読み込める様にしました。
      [ネット入力(マニュアル)]では読めません。
      “アシストツール”の[ネット入力]でも読み込めます。

【その他】

    • ミラー面付けで、部品登録時に“半田面自動生成”を行った時の軸と異なる軸で面付けした時に、
      裏面配置の部品が正しくミラーされない不具合を修正しました。
    • 輪郭データのハッチ表示をOFFにしたとき、データ層色のハッチ表示色が加色で表示される不具合を修正しました。
    • バッチDRCの「特殊」の”テーパーの有無チェック“で、不要なテーパーも同時にチェックするようにしました。
    • ベタ面自動発生で丸の打ち抜きデータが2重に作成され、ガーバー出力では抜かれない場合がある不具合を修正しました。

【制限事項】

  • マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
    各操作中に”動作を停止しました。”とエラー表示されます。
CADLUS Viewer Ver6.0.6136 リリースノート

【ガーバーイン】

    • 「ガーバーイン」でカスタムアパーチャが多く定義されたガーバーデータの読み込みが、
      正しく読み込まれない場合がある不具合を修正しました。

【制限事項】

  • マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
    各操作中に”動作を停止しました。”とエラー表示されます。
CADLUS PCB 、Viewer Ver6.0.5868 リリースノート
    • 使用部品登録・更新処理のパッド入力に、レジスト・メタルマスクの発生をする様にしました。

【全体】

    • バージョンアップ後の最初の起動で、部品ライブラリーを更新するか否かの確認メッセージを表示するようにしました。

【入力・編集】

    • 寸法線の使用少数桁数の情報を保持するように変更しました。
    • 部品配置処理で裏面に指定にして終了し、再度部品配置処理に入ると表面指定の表示のまま裏面扱いになる不具合を
      修正しました。
    • ミアンダ処理の設定(On/Off)を結線メニューの「モード設定」に追加しました。

【ネット入力】

    • CR5000フォーマット(NDFファイル)の入力で、信号名無しはNCピンとして読み飛ばす様に修正しました。
    • ネット入力画面でスクロールバーのSmall/Largeでのスクロール時に画面が更新されない不具合を修正しました。

【その他】

    • [基板見積]をクリックして、ピーバンドットコムのWebページに正常に飛ばない不具合を修正しました。
    • 連続印刷時の設定した内容が保存されない不具合を修正しました。
    • DXF出力の出力パラメータで、”レイヤ名”を指定せず、且つ「層別レイヤ出力」にチェックを入れなかった場合、
      出力されない不具合を修正しました。
    • マウント入力時の設定の不具合を修正しました。
    • ホールの画面表示色が白をグレーに戻しました。
    • スタック・テーブルの設定で、“ホール径”は円、四角、長円以外選択できないように修正しました。
    • ミラー面付けを行った際ランド状態が反転しない不具合を修正しました。

【制限事項】

  • マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
    各操作中に”動作を停止しました。”とエラー表示されます。
CADLUS Viewer Ver6.0.5721 リリースノート
  • 「印刷」-「連続印刷」と「イメージ印刷」に”表示画面”のチェックボタンを追加しました。
    オンにしますと画面表示されている領域が印刷されます。
CADLUS PCB 、Viewer Ver6.0.5697 リリースノート

【入力・編集】

    • “吸収ON”の時に、配置部品の配置基準点に対して吸収するようにしました。
    • 図形属性表示・変更にてランドやビアのランド状態を変更すると、エラーになる不具合を修正しました。
    • 参照名リナンバーの「比較ファイルからの実行」で、対象部品が存在していても、
      基板上の参照名が変わらない不具合を修正しました。
    • 層ブリンクのタイトルが図形ブリンクになっている不具合を修正しました。
    • 結線入力の結線編集にて領域選択で複数選択した後にピック選択で選択解除しても表示が変わらない不具合を修正しました。

【ネット入力】

    • ネット情報入力の「ネット入出力」-「ネット入力」に”KiCad"フォーマットを追加しました。

【その他】

    • 使用部品登録・編集処理にて半田面自動生成をした時、半田面部品の最大最小値が設定されない不具合を修正しました。
    • 基板ユーティリティの”データ交換”に「層交換」を追加しました。
    • 部品ユーティリティの部品コピー時にDコードとスタックの上書きしますかの確認メッセージの”はい”と”いいえ”の後に
      その説明を基板の圧縮保存時に上書きの確認が2回表示される不具合を修正しました。
    • ネット情報入力の”KiCAD"フォーマットを追加しました

【制限事項】

  • マイクロソフト社のOffice2010日本語IMEは使用せずに、他の日本語IMEを使用して下さい。
CADLUS Viewer Ver6.0.5 リリースノート
  • DXF出力機能を改善致しました。
CADLUS Viewer Ver6.0.5 リリースノート
    • インストールフォルダがVer5.1x、Ver2.1までと変更になりました。

Ver6.0のCADLUS Viewerをデフォルトのインストールフォルダにインストールしますと、
Ver5.1のCADLUS ViewerとVer6.0のCADLUS Viewerの2つが存在する事になります。
新たなCADLUS Oneの基板の互換性の問題もありますので、極力Ver5.1、Ver2.1のCADLUS Viewerは
アンインストールして下さい。
Ver6.0の新インストールフォルダ
例)C:\Program Files\CADLUS\CADLUS Viewer
C:\Program Files(X86)\CADLUS\CADLUS Viewer
Ver5.1x以前のインストールフォルダ
例)C:\Program Files\CADLUS Viewer
C:\Program Files(X86)\CADLUS Viewer
また、実行フォルダも、インストールフォルダでは無く、マイドキュメントに変わりますので、管理者権限を持たせなくても
実行出来る様になりました。
CADLUS Viewerの最初の起動時に、マイドキュメントの¥Nisoulの下に¥CADLUS Viewerのフォルダが作成され、
インストールフォルダのフォルダ¥SYSなどがコピーされます。

  • 画面の拡大や縮小はマウスの中ボタンの回転でも、行る様になりました。
  • 表示画面の移動はマウスの中ボタンでのドラック移動で移動できる様になりました。
  • ガーバーデータの入力では、ファイル拡張子を下記の拡張子をデフォルトに変更しましたので、
    ドキュメントやドリルのファイルが一緒に表示されにくくなりました。
    *.gbr、*.phd、*.pho、*.gsi、*.dat、*.art

Ver6.0以前の更新履歴

CADLUS Viewer V2.1.5 リリースノート
  • ガーバーインで、50を超えるOutLineで構成されているカスタムアパーチャの定義があるとダウンしてしまいましたが、
    拡張ガーバーの仕様では50ポイントまでのOutLineですが50を越えても処理出来る様に修正しました。
CADLUS PCB V5.1.5 リリースノート
  • テーパーの付き方が変更されました。
  • 特殊DRC/シルクとレジストのギャップチェックで異形パッドに対して、実行する毎にエラー箇所が変わる不具合を
    ダブルモニタチェック時のエラーメッセージを表示しない様にしました。
  • 図形ブリンク表示で表示されないDコードがある不具合を修正しました。
  • 他社ネット入出力でネットフォーマット”不明6”追加しました。
  • 他社ネット入出力でネットフォーマット”デザインスパークPCB 2”追加しました。フォーマット出力は出来ません。
  • 部品参照名の表示ボタン[表]を右クリックで表示層群パラメータの1番目の登録で、
    [裏]を右クリックで表示層群パラメータの2番目の登録で表示する様にしました。
  • 穴図出力時の基板最大値の求め方を既存の全データと外形層データの2種類から選択出来る様にしました。
  • ネット入力のバンクファイルを削除しても削除されない不具合を修正しました。
  • ネット入力のバンクファイルを読み込んでも、ネットデータを変更しないと更新されない不具合を修正しました。
  • 分岐配線長リストで表示されない事がある不具合修正しました。
CADLUS Viewer V2.1.1 リリースノート
  • 半田面視表示が出来ない場合がある不具合を修正しました。
CADLUS体験版(X) V2.1(Ver5.1) リリースノート

【全体】

    • テーパー付けの設定で、テーパーサイズではなく比率指定に変更しましたので、既存データに再度付加する場合は
      設定値を変更する必要があります。
      例)0.2 à 1.8
    • 配置部品の部品編集(変更)を出来る様にしました。オリジナル部品は変更されませんので、同一部品の他の配置部品は
      変更されません。
    • メニュー「編集」-「部品編集」に「配置部品の編集」を追加。
    • 1つの配置部品に対して複数の文字をリンクできるようにしました。
      シルク文字連結/連結解除の追加
      メニュー「編集」-「シルク編集」に「シルク文字連結」と「シルク文字連結解除」を追加。
    • 既存の部品種別以外に新たに部品種別の追加登録を出来る様にしました。既存の部品種別は変更出来ません。
    • 直線・長方形・円・円弧入力に“破線”、“一点鎖線”、“二点鎖線”の線種を追加しました。
      その線種のまま編集が出来ます。
    • 表示画面を複数画面記憶し、記憶した表示画面を再表示する機能を追加しました。(最大50画面)
    • 基板を開く、解凍読み込み、最近基板選択、新規基板作成時にその時に開いている基板表示を消さない様にしました。
      よって選択基板を未設定にするメニューを“ファイル”に追加しました。

【結線入力】

    • 束配線に“中心基準線”の設定を追加し、偶数本の束線でも束線の中心を基準に入力出来る様にしました。
    • テーパー付けで、 線幅が異なるパターン間でもテーパーが発生出来るようにしました。
      Rが付いていてもRのテーパーが発生します。
    • テーパー付けで、パターンとパットのテーパーの位置をパッドの中心ではなくパターンとパッドの交点位置に変更しました。
    • テーパー付けで、ピン番の無い部品端子(穴付きランド)にもテーパーが付くようにしました。
      パッドはピン番が無ければ付きません。
    • ピンスワップの“ピン変更・リスト”をバンク番号順に出力するように変更しました。

【基板編集】

    • 自動ベタ面発生で円弧と円弧、円弧と直線なども滑らかに発生する様にしました。
    • 自動ベタ面発生に“鋭角部分のR付け”の設定を追加し、鋭角部分にR付を行う事も出来る様にしました。
    • ライン接続処理に“直線延長接続”を追加し、従来の処理を“端点接続”として選択実行する様にしました。
    • 寸法線入力の矢印寸法の値を基板編集と部品編集とで別々に保存するようにしました。
    • パッド一括変更で丸のDコードも指定出来る様にしました。
    • 参照名クリアーに[領域選択]を追加しました。
    • 参照名リナンバーで実行時に初期化の確認メッセージを表示する様にしました。

【部品ユーティリティ】

    • 部品種別変更が出来る様に“部品種別変更”ボタンを追加しました。
    • 部品名表示を赤色表示する“強調表示”ボタンを追加しました。
    • 確認フラグを変更出来る様に“確認フラグ変更”ボタンを追加しました。
    • 部品名変更コピーで作成日を部品名変更コピーの実行日に変更しました。
    • 部品コピーで更新日を部品コピーの実行日に変更しました。

【ネット情報入力】

    • ネットのキー入力時に改行コードなどの制御コードが入力されない様にしました。
    • 他社ネット入力で”デザイン スパークPCB”フォーマットを追加しました。
    • 他社ネット入力のアレグロフォーマットで端子名'XXX'の'(シングルクォーテーション)を取り込まないようにしました。
    • 他社ネット入力の”CSI EDA5”フォーマットで信号名の先頭の#を削除しない様に変更しました。
    • 他社ネット入力で”D2CAD”フォーマットを追加しました。
    • 他社ネット入力で”不明5”フォーマットを追加しました。

【その他】

    • 図形ブリンク表示で部品内のデータもブリンクするようにしました。
    • 「表示切り替」のカスタム層表示内容を基板処理と部品処理で別に表示するようにしました。
    • クリアランス設定の径クリアランスの指定が3個まででしたが、10個までにしました。
    • バッチDRC 処理「特殊」に同電位ギャップチェックを追加しました。
    • ベタ面自動発生で出来た鋭角(90度未満)の部分にRをつけるようにしました。
    • 禁止領域チェックでパラメータの読込を追加しました。
    • グリッド設定で100mm超の数値も入力出来る様にしました。
    • 部品表入力でCADLUS部品の割り当て表でタイトル[CADLUS部品名]をクリックし、
      CADLUS部品名順に表示される様にしました。
    • 部品表入力でOrCADの部品表(xxxx.BOM)を取り込める様にしました。
    • 部品表入力で末尾が文字でも数字があれば数字部分の連続データとして読める様にしました。
      PARTS_NAME,1A/5A => 1A, 2A ,3A, 4A,A 5
    • 面付け時のX,Yのピッチの初期値に外形幅+線幅になっていましたが、線幅の考慮を止める様にしました。
    • シルクカット処理のレジスト増分値のデフォルト値を0から0.1に変更しました。
    • 画像の解像度の異なるPC間で、基板データの保存を繰り返すと設計領域がどんどん大きくなる件を修正しました。
    • フラッシュデータのランド化で、作成後に元データのフラッシュデータを削除出来る様にしました。
    • 部品生成でビアから始まる結線データのビアのテーパーが部品化されない不具合修正しました。
    • 基板ユーティリティの「データ変換」に部品と文字のリンク張替を追加しました。

【オプションソフト】

  • 3D表示で部品内のCOC層データを設定されている高さで立体表示する様にしました。
    部品参照名のみの表示でも指定領域内の部品が立体表示され、3mm以上のNTHも表示されます。
    高さが1mm以上の部品には高さ数値も表示されます。
CADLUS Viewer V2.1(Ver5.1) リリースノート
  • クロスヘアカーソルのON/OFFを追加しました。OFFにしますと十字カーソルになります。
  • 3D表示で部品内のCOC層データを設定されている高さで立体表示する様にしました。
    部品参照名のみの表示でも指定領域内の部品が立体表示され、3mm以上のNTHも表示されます。
    高さが1mm以上の部品には高さ数値も表示されます。
CADLUS Viewer V4.5 リリースノート
  • 無償ビューア、有償ビューア(レビュー)共通
  • カーソル形状をクロスヘアーカーソルに変更しました。
  • 補助機能「信号表示」の[色設定]に色設定パラメータの保存と読込機能を追加しました。
  • 距離測定処理に X側の距離成分とY側の距離成分表示を追加しました。
  • 距離測定処理で[次]ボタンを追加しました。
  • 部品ネットを行った後は全ネット表示が出来ない不具合を修正しました。
  • ガーバーインで未定義Dコードを取り込んだ場合、エラーメッセージを表示する様にしました。
  • ガーバーインで拡張ガーバーのポリゴン定義に不正な定義があっても、直線としてほぼ取り込む様にしました。
    エラーメッセージを表示します。