部品作成

部品を作成する場合、マスター部品の作成と処理基板データ部品の作成の2通りがあります。 部品マスターを作成する場合は「ファイル」-「システム設定」-「部品マスター登録・更新処理へ」 で行います。基板データの部品を作成する場合は「ファイル」-「使用部品登録・更新処理へ」で行い ます。
しかし部品マスターはシステム上(CAD上)で1ファイルだけで、穴図のマーク記号などが登録 されています。よって、機種別、お客様別など、複数の部品マスターを管理する場合は一般の基板 データ(部品データしか無い基板)で管理して下さい。

部品の新規作成例

ここでは、基板上の部品登録を例に記述します。下図の面実装の部品を新規に作ります。

部品登録処理へ

1. 「ファイル」-「使用部品の登録・更新処理へ」を選択します。
2. 「部品処理」-「新規作成」を選択します。
3. 部品サイズを指定しますが、実部品のサイズではなく、部品を作成する作業サイズを指定しますから部品外形の2、3倍くらいを指定します。ここでは10mmを指定します。

パッドを入力

 パッドをどの層に作成するかで、レジスト、メタルマスクデータになります。ここでは部品面のパッドを作成するので、現在選択層を“部品面パターン”にします。

1. 「入力」-「ランド/パッド/フラッシュ」-「パッド」を選択します。
2. パッド入力対象の層“部品面パターン”の層番号を現在選択層より選択します。
3. [端子番号]に1を入力し、[繰返し個数]に4を入力して、一度にパッドを4つ配置する設定を行います。 端子名称として使用出来る、特殊文字は$ ._ + -です。

[端子番号]が入力出来ない場合は、②で現在選択層が“部品面パターン”の層にしていません。
4. [ピッチX]には、隣り合うパッドとの間隔を指定します。1mmピッチの場合は1を設定します。 真横に配置しますので[ピッチY]には0を設定します。[繰返し個数]が0の場合は無効になります。
5. 目的のパッドがDコードで登録されていれば出力Dコードをクリックし選択します。また目的のパッドがDコードで登録されていない場合は、Dコードを登録しなくても[横幅]、[縦高]を指定して作成出来ます。
6. 端子番号1番のパッドを配置する位置をクリックします。クリックと同時に5つパッドが配置されます。端子番号は自動的に6番を示します。
7. [ピッチX]をマイナスにします。
8. 次に端子番号5番を配置する位置をクリックします。
9. [終了]ボタンをクリックして処理を終了します。
説明
[端子番号] 指定した番号が端子に表示されます。数値は自動カウントアップされます。
                AC1->AC2、 1AC->2AC
[繰返し個数] 指定個数のパッドを一度に配置します。パッドの繰り返し個数を1以上に指定した場合のみ有効な項目です。
[ピッチX] 左右のパッド同士の間隔を指定します。
[ピッチY] 上下のパッド同士の間隔を指定します。
[Dコード] 指定されたDコードのサイズのパッドが配置されます。Dコードに登録されていない場合は下記の[横幅]、[縦高]を指定します。
[横幅] パッドの横サイズを、任意の値で指定します。最後に[Enter]キーを押します。
[縦高] パッドの縦サイズを、任意の値で指定します。最後に[Enter]キーを押します。
[縦高]で最後に[Enter]キーを押しますと、[Dコード]が“----------”表示に変更されます。変更されていない場合は寸法指定が有効となっていません。
表示中のDコードが有効となります。[縦高]を指定後必ず最後に[Enter]キーを押します。
フォト出力では自動的に最適な角アパーチャで出力されます。
[矢印ボタンでピッチ変更] ピッチX/ピッチYに入力された値を矢印ボタンで符号反転します。

メタルマスクを作成

 通常メタルマスクはランドと同径ですので、層間コピーで作成します。

現在選択層を変更せずに、ツールアイコン (コピー)をクリックします。

←“層間コピーON”をクリックし、オンにします。
 コピー先の層を“部品面メタルマスク層”を選択し、[処理実行]ボタンをクリックします。

レジストを入力

 現在選択層を“部品面レジスト”にして、部品面パッドと同様に作成します。端子番号を設定出来ない以外で違いは[横幅]と[縦高]だけです。

部品のシルクを作成

部品シルクの直線、円弧の線幅は目的のDコードを選択します。0.3mmを選択します。

または

[Dコード選択]のダイアログボックスが表示されます。

シルクの線幅を選択します。選択後はここを確認して下さい

シルクを直線で入力

<手順>

①部品のシルク層番号をツールバー2より選択します。

 以後、穴付きランドデータ以外の図形データは全てこの論理層に作成されます。

②目的のグリッドの番号をクリックし設定します。

③メニュー「入力」-「直線」又はツールアイコン をクリックします。

直線にて部品シルクの形を作成します。

④始点をクリックします。後は連続して2・3点目をクリックします。

直前に入力した座標値を取消す場合は、[直前取消]ボタンをクリックするか、キーボードより[Z]

キーを選択して下さい。

⑤マウスの右ボタンをクリックして、直線の入力を終了します。

一度入力した直線を編集

 変更する必要が無い場合は次の“円弧の入力”へ進みます。

<手順>

①メニュー「編集」-「直線(R付)編集」または、 をクリックします。

②[端点の移動]を選択します。

③現在選択層に部品面シルクの層が選択されているか確認します。

④編集対象図形を選択します。

⑤移動する端点を選択します。

⑥端点の移動先位置をクリックします。継続して移動した端点を選択し、更に移動する事ができ
ます。

⑦図形の編集が終わりましたら、マウスの右クリックで編集処理を終了します。

円弧の入力

<手順>

①「入力」-「円弧:中心、始点、終点」を選択します。

②円弧の中心点、始点、終点の座標を指定し円弧を描きます。直前に入力した座標値をキャンセル
する場合は、マウスの右ボタンをクリックします。

ランド入力

リード部品など穴のあるランドを作成します。

<手順>

「入力」-「ランド/パッド/フラッシュ」-\「ランド」又は又は をクリックします。

←穴径より、目的のスタックコードを選択します。

 

[ランド入力]の場合は指定したスタック・コードで作成されますので目的のスタック・コードを

選択します。

現在選択層はどの層でもかまいません。

ホール・フラッシュ入力

<手順>

「入力」-「ランド/パッド/フラッシュ」-「フラッシュ」又は をクリックします。

現在選択層に指定したコードのデータが作成されます。

端子番号は持ちませんので、部品のレジスト、メタルマスク、合わせマークなどの作成に使用します。

端子番号を端子名に変更

<手順>

①「編集」-「図形属性表示・変更」を選択します。

②端子番号を変更する端子をクリックします。

③[端子名称]に「VC」または「GN」と入力します。

④[変更実行]ボタンをクリックし、変更を実行します。

[変更実行]ボタンの文字が青色表示されていない場合は、変更の実行は行えません。数値入力後は

[ Enter]キーを押して入力の確定を行って下さい。

⑤端子番号の変更が全て終了しましたら、[終了]ボタンをクリックしてダイアログを終了します。

部品の配置基準点を登録

ここで設定した配置基準点が基板上で部品を配置した場合の座標となります。

<手順>

①「設定」-「配置基準点設定」を選択します。

マウスポインターがクロスカーソルに変わります。

②部品の配置基準点の座標値をクリックします。

③その個所にブルーの十字マークが表示されます。

④[終了]ボタンをクリックして終了します。

マウンタ基準点設定

部品のマウンタ基準点を設定します。マウンター出力で配置基準点かマウンタ基準点座標のどちらかの選択で部品の配置座標値を出力します。

 マウンタ基準点はリード部品は 1 番端子に、面実装部品は部品の中央に設定しなければなりません。

配置基準点は基板上に部品配置する時の基準点で自由ですが、マウンタ基準点と同じにすべきです。

<手順>

①「設定」-「マウンタ基準点設定」を選択します。

マウスの表示がクロスカーソル表示に変わります。

②マウンタ基準点の座標値をクリックします。

指定した位置に白色の十字マークが表示されます。

③[終了]ボタンをクリックしてマウンタ基準点の設定を終了します。

座標値のキーボード入力

<手順>

①「設定」-「マウンタ基準点設定」を選択します。

②座標値をキー入力する為に下記のエリアをクリックします。

②対象項目にキーボードより座標値を入力します。

X,Y座標入力後は[ Enter ]キーを必ず押します。

“絶対 ” 座標の場合は指定されている仮原点の位置からとなります。

③[実行]ボタンをクリックしてマウンタ基準点を設定します。

④設定されたマウンタ基準点の場所に白色の十字マークが表示されます。

⑤再び[マウス入力]モードに切り換える場合は、[スペース]キーを押します。終了する場合は[終了]ボタンをクリックします。

部品高さ・部品外形の入力

基板上で部品の高さ、配置禁止チェックを行う場合の部品側のデータを直線データで入力して設定しておきます。

<手順>

①選択層を“部品面部品重複チェック”の層を選択します。

②ラインの幅も含めてチェックされますので目的の線幅の D コード、グリッドなどを選択しておきます。

③右側のツールバーより 「直線入力」をクリックします。

←高さは選択層を“部品面部品重複チェック”にした時のみ表示されます。

高さチェックを行う場合は [高さ ] をミリで指定します。

部品の回りの閉図形として入力します。

表部品を作成し、[部品補助機能]-[半田面部品自動生成]ボタンをクリックするだけで自動的に裏部品を作成します。

部品の登録

<手順>

①「ファイル」-「部品の保存」を選択します。

②「部品名称」に登録名称として50文字以下で入力します。大文字と小文字は区別されますので、なるべく大文字で統一して下さい。スペースと*は入力出来ません。

③「部品種別」ボタンをクリックし、リストから目的の種別を選択します。

ジャンパー部品を選択しますと、逆ネット抽出処理でジャンパー部品の扱いになり、部品と扱われませんので、この部品端子のネットデータがある場合は異ネットとなります。

その他の種別は影響しません。

④「部品高さ」に部品の高さをmmで入力します。マウントデータの出力に出力されますが、実際は必要有りません。

⑤「確認フラグ」新規作成時や旧部品を更新した場合などは“未”設定するなど、部品管理に使用します。

⑥[実行]ボタンをクリックします。

⑦[新規部品登録確認]メッセージが表示されますので、[はい]ボタンをクリックします。

作成された部品は" DIP14 " という名前で基板データ中に部品登録されました。

その他の入力メニュー

ランド/パッド/フラッシュ・直線・円弧以外にも[入力]メニューには各種のメニューがあります。

長方形

<手順>

①作成する長方形の対角2点のうち、1点目の座標値をクリックします。

②1点目の座標値をキャンセルする場合は、マウスの右ボタンをクリックします。

③次に2点目の座標値を1点目の座標値の対角腺上でクリックします。

円:中心と半径

①作成する円の中心点をクリックします。マウスを動かしますと作成される円のイメージが白色で表示されます。

②目的の半径サイズの位置でクリックします。

直前に入力した座標値を取り消す場合は、マウスの右ボタンをクリックします。

円:3点指定

円上の3点の座標値を入力し、円を作成します。

<手順>

①1点目を入力してマウスを動かしますと画面に作成される円のイメージが白色で表示されます。

②2点目、3点目を入力しますと、3点を通る円を作成します。

輪郭線

←座標補正をする場合は[座標補正法指定なし]をクリックして座標補正法リストより選択して下さい。

<手順>

①始点入力後、連続して座標値をクリックします。

直前に入力した座標値を取消す場合は、[直前取消]ボタンをクリックするか、キーボードより[Z]キーを押して下さい。

②マウスの右ボタンをクリックした時点で自動的に始点と結ぶ閉図形を作成します。尚、3点以上
入力しないと右クリックで終了できません。

打抜線

すでに作成されている輪郭線に打抜線を入力します。

①打抜線処理を行う輪郭線図形をクリックします。選択した輪郭線図形は白色で表示されます。

②打抜線の入力方法は、輪郭線入力と同様に行います。

寸法線

「入力」-「寸法線入力」を選択します。

[文字高さ][文字幅][文字間隔][矢印寸法]は下記の図のようになっております。

 文字の線幅は設定 D コードの幅となります。

よく使用する文字サイズ[文字高さ]、[文字幅]、[文字間隔]、文字の線幅 D コードをあらかじめ設定しておき、使用時に設定番号をクリックすると[矢印寸法]と文字の線幅以外の設定値が寸法線入力のウィンドーにセット(コピー)されます。

寸法線の入力方法には、[寸法線1点指定]・[寸法線2点指定]・[径寸法線]・[ラベル寸法線]・[角度寸法線]の5通りがあります。

をクリックし目的の寸法線を選択します。

最初の共通手順

①[文字高さ][文字幅][文字間隔][矢印寸法]の各値を指定するか、文字設定表の番号を
クリックします。文字線幅以外が設定されます。

②[出力層]を指定します。

③文字線幅を より選択します。

[吸収モードON]: [寸法線1点指定]以外の入力で 表示されます。チェックを入れておきますと2点の指定時に端点吸収が容易に行えます。

[小数点桁数]:寸法値の小数点以下の表示を制限します。デフォルトとして小数点2桁表示が設定されています。

寸法線1点指定

対象図形の1辺を指定して寸法を測り寸法を作成します。

寸法線1点指定の時のみ[線分の長さ:(表示)]が有効となります。線分の寸法値がカッコ内に表示されます。

寸法を図形の「中心」/「内側」/「外側」のどのポイントで計測するかを、ボタンのクリックにより選択できます。

ボタンをクリックする度に、

とローテーションし切り替わります。

<手順>

①寸法を取る直線データの線上のポイントを選択します。手前の操作を取り消す場合はマウスを右クリックします。

対象にした直線データが斜め線の場合、下図のように引き出し線は2つになります。

水平、垂直の場合、引き出し線は1つです。

②マウスを動かし、表示する寸法線の引き出し部分の長さを決めます。

③寸法線の長さが決まりましたら、その位置でマウスをクリックします。

寸法線長よりも距離を示す文字表示が長くなった場合は、矢印表示は表示されません。

線分長の表示]は寸法線の長い方に表示されます。

寸法線2点指定

ランドや直線を対象に指定した、2点間の寸法を測り寸法を作成します。

手前の操作を取り消す場合はマウスを右クリックします。

<手順>

①最初の寸法を取るポイントを選択します。

②寸法を計る直線の2点目の座標値を指定します。

③マウスを動かし、表示する寸法線の引き出し部分の長さを決めます。

②の2点目の座標値により、対象寸法が1点目と2点目で斜めになる場合は下図のように 引き出し線は2つになります。水平、垂直の場合は引き出し線は2つです。 

④寸法線の長さが決まりましたら、その位置でマウスをクリックします。

寸法線長よりも距離を示す文字表示が長くなった場合は、矢印表示は表示されません

径寸法線

ランド、円の直径、円弧、R付き直線のR、直線の長さを測り寸法を作成します。

手前の操作を取り消す場合はマウスを右クリックします。

<手順>

①寸法を取るランド、円、円弧、R付き直線、直線データの線上のポイントを選択します。

②マウスを動かし、表示する寸法線の引き出し部分の長さを決めます。

③寸法線の長さが決まりましたら、その位置でマウスをクリックします。

寸法を取るデータがランド、円の場合は先頭文字にφが付きます。
円弧、R付き直線データの場合は先頭文字にRが付きます。
直線データの場合は先頭文字が付きません。

ラベル寸法線

対象データに関係せず、文字を入力して指定場所に寸法を作成します。

手前の操作を取り消す場合はマウスを右クリックします。

<手順>

①文字の入力枠をクリックし、文字を入力します。

②マウスを動かし、表示する寸法線の引き出し部分の長さを決めます。

③寸法線の長さが決まりましたら、その位置でマウスをクリックします。

角度寸法線

2 つの直線データを指定してその 2 つの直線間の角度を指定場所に作成します。

180 度未満の角度が対象となり、対象データは直線データだけです。

手前の操作を取り消す場合はマウスを右クリックします。

<手順>

①線分をクリックします。

②他の線分をクリックします。

③①と②の交点よりマウス位置までの半径で寸法線(円弧)が作成されます。

←中央のエリアは 180℃を越える為に指定出来ません

マニュアル

インストール後の設定方法

基本操作

  • 部品作成
  • 配置
  • 配線
  • 印刷
  • CAM入出力
  • 同時並行設計

マニュアルダウンロード

ダウンロードはこちら

CADLUS One 製品をお買い上げのお客様向けの製品マニュアル(PDFファイル)のダウンロードが行えます。

まずはこちらをご覧ください

よくある質問(FAQ)

CADLUS One 製品全般に関するよくあるご質問にお答えしています。

お気軽にお問い合わせください

電話問い合わせ

CADLUS One サポート担当が丁寧にご対応いたします。

メールでのお問い合わせはこちら

サポートお問い合わせ

保守サポート対応のメール窓口です。素早い対応でサポートを行います。